MoneyPlex übertragen von SUSE Linux 10.0 auf Open Suse 10.2

warning: fread(): Length parameter must be greater than 0 in /var/www/elchs-kramkiste.de/lapurd/includes/common.inc(1695) : eval()'d code on line 19.

MoneyPlex 2007 von Matrica war auf einem Suse 10.0 System installiert. Nachdem ich mir auf einem neuen PC OpenSuse 10.2 in der 64-Bit-Ausgabe eingerichtet hatte, stand nun der Umzug der MoneyPlex-Anwendung an. Ich wollte aber nicht nur die Daten überführen, sondern alle Einstellungen usw. Daher habe ich zuerst einmal von der Installations-CD der Version 6.0 (2004) MoneyPlex installiert, anschließend das Installationsverzeichnis /home/MeinName/moneyplex umbenannt in /home/MeinName/moneyplex.sik. Nun das Verzeichnis /home/MeinName/moneyplex vom alten PC in eine *.tar.gz-Datei gepackt, diese per USB Stick auf den neuen PC kopiert, dort wieder nach /home/MeinName/moneyplex entpackt (Vorsicht: Nicht nach /home/MeinName/moneyplex/moneyplex) entpackt über das KDE-Icon gestartet. Nach einer Testanmeldung ohne Chipkarte (weil die noch nicht lief) habe ich kurz die vorhandenen Daten meiner 2 Online-Konten durchgesehen und festgestellt, dass Alles da war.

Nun zur Chipkarte: Ich benutze als Kartenterminal ein Kobil Pro USB mit eigener Tastatur. Dieser konnte aber von MoneyPlex nicht angesprochen werden. Kurze Internet-Recherche in einem Forum zum Online-Banking, bei Matrica und dann von Kobil die neuesten Treiber für mein Karten-Lesegerät gezogen und nach /home/MeinName/moneyplex/ctapi installiert.

Hinweis: Trotz meines 64-Bit-Systems mussten die 32-Bit-Treiber installieren werden, da MoneyPlex eine 32-Bit-Anwendung ist (siehe auch Readme.txt bei den Kobil-Treibern).

In MoneyPlex unter Einstellungen / Chipkartenleser / CTAPI-Treiber von

/home/MeinName/moneyplex/ctapi/libct_kobil_pro_usb.so

auf

/home/MeinName/moneyplex/ctapi/libct_kobil.so

umgestellt und (nach Neustart) konnte ich auch wieder voll auf meine Chipkarten zugreifen, online meine Kontendaten abrufen usw.

Operation gelungen, MoneyPlex lebt ;-)