Linux-System laggt bzw. lässt sich nur sehr zäh bedienen

warning: fread(): Length parameter must be greater than 0 in /var/www/elchs-kramkiste.de/lapurd/includes/common.inc(1695) : eval()'d code on line 19.

Zum wiederholten Mal ließ sich mein OpenSuse 11.1 mit KDE 4 unmittelbar nach dem Hochfahren des Systems nur sehr zäh bedienen. Teilweise reagierte der PC sekundenweise auf Mausklicks oder Tastatureingaben gar nicht oder das z.B. Scrollen von Web-Inhalten lief in Zeitlupe ab.

Grund dafür war PulseAudio (also der Sound-Dämon bzw. -Server), welcher eine sehr hohe Systemlast erzeugte.

Hier mal die Anzeige von top in einer Konsole:

top - 08:11:54 up 6 min,  3 users,  load average: 2.73, 2.09, 0.99
Tasks: 132 total,   2 running, 130 sleeping,   0 stopped,   0 zombie
Cpu(s): 17.6%us,  2.9%sy,  0.0%ni, 16.5%id, 33.0%wa, 29.9%hi,  0.0%si,  0.0%st
Mem:   1792800k total,   715308k used,  1077492k free,    77592k buffers
Swap:  2096440k total,        0k used,  2096440k free,   387704k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 3896 user1     20   0 95080 4796 3652 S   69  0.3   2:11.74 pulseaudio
 2996 root      20   0  382m  62m  11m S    9  3.5   0:24.64 Xorg
 3811 user1     20   0  162m  26m  13m S    7  1.5   0:12.41 knotify4
 4011 user1     20   0 92968  17m  12m S    3  1.0   0:01.52 konsole
 2171 root      20   0  3256 1476  556 R    2  0.1   0:04.52 syslog-ng
 3798 user1     20   0  236m  22m  17m S    1  1.3   0:02.32 kwin
 4022 user1     20   0  2416 1004  768 R    1  0.1   0:00.26 top
    1 root      20   0  1008  356  308 S    0  0.0   0:01.58 init
    2 root      15  -5     0    0    0 S    0  0.0   0:00.00 kthreadd
    3 root      RT  -5     0    0    0 S    0  0.0   0:00.00 migration/0
    4 root      15  -5     0    0    0 S    0  0.0   0:00.04 ksoftirqd/0

Wie Sie sehen, erzeugt "pulseaudio" (Spalte COMMAND) eine CPU-Last von 69 % (Spalte %CPU), was aber noch längst nicht der Spitzenwert war (zeitweise über 80 %).

Nachdem ich mich dann in der Konsole als root angemeldet habe, reichte ein

#: kill -9 3896

um das System "wieder flott zu machen". Damit wird PulseAudio, das lt. Liste oben die Prozess-ID 3896 (Spalte PID) hat, beendet (evtl. hätte ich dies aber auch als Benutzer user1 machen können, da PulseAudio ja als von diesem gestartet angezeigt wurde).

Ursache für den ressourcenfressenden Soundserver ist ein manchmal beim Systemstart nicht gefundenes Audio-Device (die Sound-"Karte"), wofür ich noch keine dauerhafte Lösung habe.